Intermediate Connection Failures
Incident Report for InscribeAI, Inc.
Resolved
This incident has been resolved.
Posted Oct 22, 2020 - 11:32 UTC
Monitoring
Users may have experienced a 502 Error when loading the app - we have implemented a fix and are monitoring the results, everything should be back to normal now.
Posted Oct 22, 2020 - 11:27 UTC