Intermittent document processing delays
Incident Report for Inscribe
Resolved
This incident has been resolved.
Posted Jan 05, 2021 - 19:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 05, 2021 - 18:52 UTC
Investigating
We are currently investigating this issue.
Posted Jan 05, 2021 - 18:33 UTC
This incident affected: US (API).